Gradle version 2.2 is required. Current version is 2.10 –

Development issue/problem:

I’m trying to use Gradle’s image. It gives me a bad idea to say that

But my grab-hook envelope… contains gradle-2.4-all.zip. I changed it to gradle-2.2-all.zip
Still the same problem.

When I launch the Gradle version into the terminal, Gradle 2.10 appears as the version.

How can this be corrected?

my basic file

build {repositories {jcenter()}dependencies {classpath ‘com.android.tools.build:gradle:1.3.0’}}}}

all projects {
repositories {
jcenter()
}
}

How can I solve this problem?

Solution 1:

  1. An open diploma package. Characteristics.
  2. Change this rule:

distributionUrl=https://services.gradle.org/distributions/gradle-2.4-all.zip

с

distributionUrl=https://services.gradle.org/distributions/gradle-2.8-all.zip

  1. Navigate to build.gradle (project: your_app_name).
  2. Change this line

Classpath ‘com.android.tools.build:gradle:XXX’.

Sync and corrections by n17t01

Classpath ‘com.android.tools.build:gradle:2.0.0-alpha3’.

or

Classpath ‘com.android.tools.build:gradle:1.5.0’.

  1. Do not press Sync now
  2. Select File -> Invalid Cache/Restart . from the menu.
  3. Select the first option : Invalid and reset

The Android studios are about to restart. After that, it should work well

I hope this helps.

Solution 2:

The VersionCheck is currently being redefined: In your looks.

Assembly scenario {

System Properties[‘com.android.build.gradle.overrideVersionCheck’] = ‘true’

}

See this link for more information

Solution 3:

Just change the build.gradle file

Classpath ‘com.android.tools.build:gradle:1.3.0’.

At the following address:

Classpath ‘com.android.tools.build:gradle:2.0.0’.

  1. Now select in the menu GoTo -> File -> Invalid Cache/Reboot…
  2. Select the first option : Invalid and reset

The Android studios are about to restart.

After that, everything should work normally.

Solution 4:

Based on
https://developer.android.com/studio/releases/gradle-plugin.html .

The following table shows which version of the Gradle plugin is required for each version of the Android plugin for Gradle.
For best results you should use the latest version of Gradle and the Android plugin.

Therefore, the version of the plugin must match the required Gradle.

See also  Who Scored The Most Runs In Asia Cup 2012?

Give here a description of the image

Solution No 5:

This is what I did to fix it:

1) Create a new project

2) Open the gradle-wrapper.properties file and copy for example B. the Url distribution to your :

distributionUrl=https://services.gradle.org/distributions/gradle-3.2-all.zip

3) Open build.gradle (project) and copy the gradle dependency to your project, for example B :

Classpath ‘com.android.tools.build:gradle:2.3.0-beta1’.

4) File -> Invalid cache / restart (I think a resynchronization would have been enough, but I did not try).

5) Delete the created project (optional).

Look, it’s a stupid way to do things, but Android Studio is free, so who am I to complain….

Solution No 6:

To solve this problem, use the ./gradlew instead of the gradlew.

Solution No 7:

The version of Android Studio and Gradle seems to be very poorly managed. And there are many problems with the functionality of the versions. And the error message is largely unrecognizable. For this particular issue. The following answer comes from Jitendra Singh. Change the version to :

Classpath ‘com.android.tools.build:gradle:2.0.0’.

But in my case: Android Studio 2.2 RC, I’m getting another error:

Cannot find a suitable builder: com.android.build.gradle.internal.LibraryTaskManager(org.gradle.api.internal.project.DefaultProject_Decorated, com.android.builder.core.AndroidBuilder, android.databaseinding.tool.DataBindingBuilder, com.android.build.gradle.LibraryExtension_Decorated, com.android builder.gradle.internal.SdkHandler, com.android buildle gradle.internal.DependencyManager, orgdle gradle.tooling.provider.model.internal.DefaultToolingModelBuilderRegistry)

So I went to maven central to find the latest version of com.android.tools.build:gradle, which is currently 2.1.3. So, after the switch to

build {repositories {mavenCentral()}dependencies {classpath ‘com.android.tools.build:gradle:2.1.3’}}dependencies {classpath ‘com.android.tools.build:gradle:2.1.3’}.

I finally solved my problem.

Solution No 8:

I had a similar problem. Each project has its own valuation folder, check if there is another valuation folder in the root of the project:

/my_projects_root_folder/project/gradle
/my_projects_root_folder/gradle

If so, you will find /gradle/wrap/gradle-wrap.properties in each directory.

Check that the version of the properties envelope in the /my_projects_root_folder/gradle/gradle-wrapper.properties folder is at least identical to the version /my_projects_root_folder/ project / gradle/ gradle-wrapper.properties.

See also  Dell Precision 3551 Specs – Detailed Specifications

Or delete / rename /my_projects_root_folder/gradle and restart androidstudio and let gradle sync and download the gradle you want.

Good luck!

Related Tags:

process system not responding chromebook,huawei home isn't responding,my iphone isn't responding,sony xperia e5 process system not responding,pixel 2 xl process system isn t responding,swin8launcher isn t responding android box,apps isn t responding,isn't responding meaning in hindi,system ui not responding pixel 1,huawei home isn t responding,system launcher not responding xiaomi,acer home not responding,google play services keeps stopping,home isn t responding,process system isn't responding chromebook,how to fix process system isn't responding android,process system isn't responding android emulator,process system isn't responding redmi note 3,how to fix process system isn t responding vivo,process com.android.phone isn't responding moto e4 plus,system ui isn't responding,mobile services isn't responding in moto e4 plus